Imagine Learning Twig Science - District Administrators are unable to access admin dashboard
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 06:02 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Sep 27, 2022 - 12:24 MST
Investigating
Our team is actively investigating an issue impacting District Administrator users of Twig Science.

The District Administrator dashboard is currently not displaying any content on the screen.

District Administrators can continue to access teaching content by changing the page URL to: ms.twigscience.com/teacher-dashboard and switching to Elementary option on the menu.

Students and teachers are not impacted by this issue and can use the system without interruption.

We apologize for the inconvenience and will provide an update soon.
Posted Sep 27, 2022 - 11:55 MST
This incident affected: Core Curriculum (Imagine Learning Twig Science).