Imagine Edgenuity - Some users are unable to login
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 16:05 MST
Monitoring
A fix has been implemented and we are monitoring the results.

Users may need to clear their browser cache if they continue to experience issues. If assistance is needed doing so or any problem persists, please reach out to Product Support for further assistance.
Posted Sep 28, 2022 - 13:29 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity - as well as - Imagine MyPath Legacy and Imagine Purpose Prep 6-12.

Students and Educators may experience slowness or errors when logging in.

We apologize for the inconvenience and will provide an update soon.
Posted Sep 28, 2022 - 13:07 MST
This incident affected: Courseware (Imagine Edgenuity), Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Virtual School Services (Imagine Instructional Services), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose 6-12).