Imagine Learning Products Experiencing Slowness and Errors
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Nov 01, 2022 - 13:05 MST
Monitoring
Our tools provider has implemented a fix and we are monitoring the results.
Posted Nov 01, 2022 - 12:24 MST
Identified
Our team has identified an issue impacting users of Imagine MyPath K-12, Imagine Odysseyware, CTE courses in Imagine Edgenuity, Imagine Reading, and Imagine Lectura. This issue is related to a system outage being experienced by one of our tools providers.

Until this outage is resolved, students may receive errors while completing activities.

We apologize for the inconvenience and will provide an update soon.
Posted Nov 01, 2022 - 11:27 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Lectura, Imagine Reading, Imagine Purpose Prep K-5) and Courseware (Imagine Edgenuity, Imagine Odysseyware).