Imagine Edgeex / Imagine Edgenuity - Students and Educators can not access activities that utilize Gizmos

Incident Report for Imagine Learning

Resolved

This incident has been resolved.
Posted Sep 19, 2025 - 12:30 MST

Identified

We have confirmed that the third-party vendor providing the Gizmos is experiencing issues. We are actively monitoring the situation and will provide updates.
Posted Sep 19, 2025 - 09:17 MST

Update

We are continuing to investigate this issue.
Posted Sep 19, 2025 - 07:43 MST

Investigating

Our team is actively investigating an issue impacting users of Imagine Edgenuity, Imagine EdgeEX, Instructional Services, and Academies.

Students and Educators can not access activities that utilize Gizmos

We apologize for the inconvenience and will provide an update soon.
Posted Sep 19, 2025 - 07:30 MST
This incident affected: Courseware (Imagine Edgenuity, Imagine EdgeEX), Virtual School Services (Imagine Instructional Services), and Academies (Imagine Learning Excellence Academy).