We are happy to report that users should now be able to resume activities without difficulty.
We apologize for the prior inconvenience.
Posted Dec 06, 2025 - 10:33 MST
Investigating
The plagiarism checker used for Imagine Edgenuity and Imagine EdgeEX writing activities is currently not returning results. We are working with the vendor to resolve the issue as quickly as possible.
Students can continue progressing through their coursework. Teachers who rely on plagiarism reports will be affected until the issue is fixed.
We will share updates as soon as more information is available. Thank you for your patience.
Posted Dec 06, 2025 - 10:26 MST
This incident affected: Courseware (Imagine Edgenuity, Imagine EdgeEX), Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), and Virtual School Services (Imagine Instructional Services).