Imagine MyPath, Imagine Lectura, Imagine Reading Reports Unavailable
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Sep 08, 2022 - 09:31 MST
Update
We are happy to report that Educators should now be able to load reports.

We apologize for the prior inconvenience.
Posted Sep 08, 2022 - 07:34 MST
Monitoring
Our team is actively investigating an issue impacting users of Imagine MyPath, Imagine Lectura, and Imagine Reading.

Educators are unable to load reports.

We apologize for the inconvenience and will provide an update soon.
Posted Sep 08, 2022 - 07:18 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Lectura, Imagine Reading).