Imagine Edgenuity - Student and Educators unable to load content or administer schools
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Sep 12, 2024 - 16:42 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Sep 12, 2024 - 16:30 MST
Update
We are continuing to investigate this issue.
Posted Sep 12, 2024 - 16:22 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity - as well as - Imagine MyPath Legacy and Imagine Purpose 6-12.

Students may not be able to load content. Educators may not be able to administer schools or get Admin reports.

We apologize for the inconvenience and will provide an update soon.
Posted Sep 12, 2024 - 15:38 MST
This incident affected: Courseware (Imagine Edgenuity, Imagine EdgeEX), Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Virtual School Services (Imagine Instructional Services), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose 6-12).