Imagine Language & Literacy and Imagine Español: Admin Users Cannot Open the Cumulative Performance Report

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted 1 month ago. Feb 25, 2025 - 09:14 MST

Investigating

Our team is actively investigating an issue impacting admin users of Imagine Language & Literacy and Imagine Español.

Administrators are not able to open the Cumulative Performance Report.

We apologize for the inconvenience and will provide an update soon.
Posted 1 month ago. Feb 25, 2025 - 08:26 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy, Imagine Español).