Imagine Language and Literacy Incident
Incident Report for Imagine Learning
Resolved
We are happy to report that Students should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Sep 06, 2023 - 15:43 MST
Identified
Our team is actively investigating an issue impacting users of Imagine Language and Literacy.

Students that have a pending assessment from NWEA or Imagine Galileo are unable to use Imagine Language and Literacy. We have identified the issue and are working on a fix.

We apologize for the inconvenience and will provide an update soon.
Posted Sep 06, 2023 - 12:22 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy).