Twig Science - District Administrators Not Able to Log In

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Jan 21, 2025 - 16:49 MST

Investigating

Our team is actively investigating an issue impacting District Administrators of Twig Science.

District Administrators are not able to successfully log in. They see a blank page after entering their credentials.

We apologize for the inconvenience and will provide an update soon.
Posted Jan 21, 2025 - 16:23 MST
This incident affected: Core Curriculum (Twig Science).