Twig Science - California Teachers See Error Message on Dashboard and Science Glossary
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Jan 17, 2024 - 11:25 MST
Investigating
Our team is actively investigating an issue impacting Twig Science teachers located in California.

Teachers see an error message on the Dashboard and the Science Glossary. These error messages do not impact use of the application.

We apologize for the inconvenience and will provide an update soon.
Posted Jan 17, 2024 - 10:49 MST
This incident affected: Core Curriculum (Twig Science).