Imagine Learning Classroom - Users Experiencing Slowness
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Sep 27, 2023 - 20:50 MST
Identified
We have degraded performance again. We are working on deploying a new solution.

We will continue to update progress.
Posted Sep 27, 2023 - 18:36 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Sep 27, 2023 - 12:32 MST
Identified
Our team has identified the cause of the issue and are planning to deploy a solution by 4 pm ET.

We will continue to update progress.
Posted Sep 27, 2023 - 10:21 MST
Update
We are continuing to investigate this issue.
Posted Sep 27, 2023 - 10:02 MST
Investigating
Our team is actively investigating an issue impacting users of products supported by the Imagine Learning Classroom.

Once users have logged in, they may experience slowness.

We apologize for the inconvenience and will provide an update soon.
Posted Sep 27, 2023 - 10:01 MST
This incident affected: Core Curriculum (Imagine Learning Illustrative Mathematics, Imagine Learning EL Education, Imagine Learning Guidebooks, Imagine Learning Odell Education).