Twig Science - Users Cannot Open Login Page
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Jun 17, 2024 - 02:08 MST
Identified
Our team has identified the cause of the issue and are preparing to deploy a solution.

We will continue to update progress.
Posted Jun 17, 2024 - 01:57 MST
Investigating
Our team is actively investigating an issue impacting users of Twig Science.

Students and Educators of Elementary and Middle Schools cannot open the page to log in directly, and logging in fails from the SSO provider.

We apologize for the inconvenience and will provide an update soon.
Posted Jun 16, 2024 - 18:47 MST
This incident affected: Core Curriculum (Twig Science).