Imagine Learning Supplemental Products - Educators experiencing degraded experience
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Nov 29, 2022 - 11:21 MST
Monitoring
Our team have identified the issue impacting Educators of most of the Imagine Learning Supplemental products. After login some features are not working.

We have taken actions to resolve and are monitoring the situation.

We apologize for the inconvenience and will provide an update soon.
Posted Nov 29, 2022 - 10:06 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy, Imagine Español, Imagine Lectura, Imagine Reading, Imagine Galileo).