Imagine Edgenuity Some Students Cannot Login or Complete Activities
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Sep 07, 2022 - 18:26 MST
Identified
Our team has identified the cause of the issue and are preparing to deploy a solution.

We will continue to update progress.
Posted Sep 07, 2022 - 18:05 MST
Update
We are continuing to investigate this issue.
Posted Sep 07, 2022 - 17:59 MST
Update
We are continuing to investigate this issue.
Posted Sep 07, 2022 - 17:51 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity - as well as - Imagine MyPath Legacy and Imagine Purpose Prep 6-12.

Some students may not be able to log in or complete activities.

We apologize for the inconvenience and will provide an update soon.
Posted Sep 07, 2022 - 17:51 MST
This incident affected: Courseware (Imagine Edgenuity), Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Virtual School Services (Imagine Instructional Services), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose 6-12).