ClassLink Login Issues
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Jul 03, 2024 - 08:22 MST
Identified
We have confirmed with ClassLink that they are having issues. For more information, please visit their status page status.classlink.com. We will continue to update here as well.
Posted Jul 03, 2024 - 06:46 MST