Imagine Instructional Services - Elementary and Carone Learning Courses Unavailable
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Sep 28, 2023 - 15:22 MST
Investigating
We have been notified that one of our vendor partners is experiencing an incident that impact the elementary and Carone Learning courses used by Imagine Instructional Services and some Academies.

We will continue to monitor the situation and keep you posted.
Posted Sep 28, 2023 - 13:15 MST
This incident affected: Academies (Imagine Learning Excellence Academy, Giant Campus) and Virtual School Services (Imagine Instructional Services).