We are happy to report that users should now be able to resume activities without difficulty.
We apologize for the prior inconvenience.
Posted Sep 03, 2024 - 06:48 MST
Monitoring
Our team has implemented a solution to the block on rostering, and we are actively monitoring the latest rostering cycle to ensure no further issues are present. A small number of students and teachers may still be unable to access recently assigned lessons and sessions, however, we are continuing to implement a solution for all affected customers.
We will continue to update this status as we progress with this effort.
Thank you for your patience.
Posted Aug 29, 2024 - 09:10 MST
Identified
We have identified an issue with the creation of new users and updating of existing users.
Impacted users may experience issues accessing the platform.
We apologize for the inconvenience and will provide updates as they become available.
Posted Aug 27, 2024 - 12:10 MST
This incident affected: Core Curriculum (Twig Science).