Imagine Odysseyware - Some users cannot log in or use the application.
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Jan 26, 2023 - 13:13 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Jan 26, 2023 - 09:54 MST
Investigating
Our team is actively investigating an issue impacting some users of Imagine Odysseyware. We confirmed that some users cannot log in or use the application.

We apologize for the inconvenience and will provide an update soon.
Posted Jan 26, 2023 - 08:21 MST