Reports for Imagine Language & Literacy are not operational
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Nov 16, 2022 - 13:43 MST
Update
We are continuing to monitor for any further issues.
Posted Nov 16, 2022 - 11:29 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2022 - 11:29 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Language & Literacy.

Educators unable to generate reports and have issues navigating through the application.

We apologize for the inconvenience and will provide an update soon.
Posted Nov 16, 2022 - 11:14 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy).