Imagine Edgenuity unavailable for some Educators
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Mar 07, 2023 - 17:35 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Mar 07, 2023 - 17:31 MST
Update
We are continuing to investigate this issue.
Posted Mar 07, 2023 - 17:21 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity. Educators may be unable to access the product.

We apologize for the inconvenience and will provide an update soon.
Posted Mar 07, 2023 - 17:17 MST
This incident affected: Courseware (Imagine Edgenuity), Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Virtual School Services (Imagine Instructional Services), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose 6-12).