Imagine EdgeEX and Imagine Edgenuity - Users may experience issues logging in and slowdowns within the system
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted May 13, 2024 - 14:28 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 13, 2024 - 14:23 MST
Identified
The issue has been identified and a fix is being implemented.
Posted May 13, 2024 - 14:20 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine EdgeEX and Imagine Edgenuity.

Some Students and Educators may experience issues logging in and may experience slowdowns within the software while logged in.

We apologize for the inconvenience and will provide an update soon.
Posted May 13, 2024 - 14:16 MST
This incident affected: Courseware (Imagine Edgenuity, Imagine EdgeEX).