Some customers may experience slowness within the application
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Jun 06, 2022 - 15:02 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2022 - 11:25 MST
Investigating
We are currently investigating this issue.
Posted Jun 06, 2022 - 09:59 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2022 - 09:49 MST
Update
Our team is actively investigating an issue impacting users of Imagine Edgenuity.

Some students and educators could experience slowness within all areas of the application.

We apologize for the inconvenience and will provide an update soon.
Posted Jun 06, 2022 - 08:51 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity.

Some students and educators could experience slowness within all areas of the application.

We apologize for the inconvenience and will provide an update soon.
Posted Jun 06, 2022 - 08:32 MST
This incident affected: Academies (Edgenuity Virtual Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Virtual School Services (Imagine Instructional Services), Courseware (Imagine Edgenuity), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose Prep 6-12).