Clever via SAML SSO Experiencing Issues

Incident Report for Imagine Learning

Resolved

Clever is reporting that their issue is resolved.
Posted Jan 15, 2026 - 17:57 MST

Investigating

Clever has informed us of an issue impacting logins for customers using SAML applications. We are monitoring the situation. For the latest updates, please visit status.clever.com.
Posted Jan 14, 2026 - 10:18 MST