Clever - SSO experiencing issues

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Oct 07, 2024 - 12:06 MST

Investigating

We have been notified by Clever that their service is degraded. For more information, please visit their StatusPage, status.clever.com, for updates.
Posted Oct 07, 2024 - 11:40 MST