Twig Science - Users Seeing Blank Screen or Errors
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Sep 13, 2024 - 12:59 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Sep 13, 2024 - 10:39 MST
Update
While we believe these issues are resolved, please contact Support if you are continuing to see issues with blank screen or 404 errors.
Posted Sep 13, 2024 - 10:29 MST
Identified
Our team has identified the cause of the issue for blank screen. If a user has a blank screen, they can refresh to restore their experience.

We will continue to update progress.
Posted Sep 13, 2024 - 09:26 MST
Investigating
Our team is actively investigating an issue impacting users of Twig Science.

Some users are presented blank screens when using the application.

We apologize for the inconvenience and will provide an update soon.
Posted Sep 13, 2024 - 09:19 MST
This incident affected: Core Curriculum (Twig Science).