Imagine Language & Literacy, Imagine Español, and Imagine Math Facts - Latest ChromeOS
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted May 09, 2023 - 10:02 MST
Update
Our team has also implemented a solution for Imagine Math Facts, and we are continuing to monitor for any remaining issues.
Posted May 08, 2023 - 16:08 MST
Monitoring
Our team has implemented a solution for Imagine Language & Literacy and Imagine Español, and we are actively monitoring to ensure no further issues. We are continuing to work on a solution for Imagine Math Facts.

Thank you for your patience.
Posted May 05, 2023 - 14:51 MST
Identified
Our team has identified the cause of the issue.

We will continue to update progress.
Posted May 04, 2023 - 17:02 MST
Investigating
We have noticed some impact to Imagine Language & Literacy, Imagine Español, and Imagine Math Facts products relating to the latest ChromeOS updates and are actively investigating. If you are experiencing related issues, please contact our support team at https://www.imaginelearning.com/support/customer-support/.
Posted May 04, 2023 - 15:11 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy, Imagine Español, Imagine Math Facts).