Salesforce has restored service and system performance has remained stable following one hour of monitoring. The intermittent degradation impacting Salesforce and related ILOD functionality appears to be resolved. We will continue to monitor, but no further impact is expected at this time.
We apologize for the prior inconvenience.
Posted Sep 16, 2026 - 06:29 MST
Update
Salesforce has restored service, and we are actively monitoring to ensure no further issues.
Thank you for your patience.
Posted Sep 16, 2026 - 06:06 MST
Monitoring
Salesforce has implemented a solution, and we are actively monitoring to ensure no further issues.
Thank you for your patience.
Posted Sep 16, 2026 - 05:52 MST
Identified
We are currently experiencing intermittent performance degradation resulting from an incident on Salesforce's platform. Salesforce's technical team has been notified and is actively investigating the issue to implement a resolution.
Please note that this disruption may also affect educators access to ILOD-related features and functionality that depend on Salesforce services.
We apologize for the inconvenience and will provide an update soon.
Posted Sep 16, 2026 - 05:12 MST
This incident affected: IL On Demand (Professional Learning Self Service, Product Allocation Self Service).