Imagine Edgenuity Slowness and Intermittent Errors
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Jul 28, 2022 - 19:02 MST
Monitoring
This morning, Amazon Web Services (our cloud provider) experienced a regional failure in the Eastern U.S., which impacted some of our districts' ability to access the Imagine Edgenuity platform. This platform hosts Imagine Edgenuity, Purpose Prep 6-12, and MyPath Legacy. AWS has resolved the issue, and all customers should be able to log in successfully, although we are continuing to monitor.
Posted Jul 28, 2022 - 12:24 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity - as well as - Imagine MyPath Legacy, Imagine Purpose Prep 6-12, and Imagine Pathblazer.

Students and Educators are seeing intermittent errors.

We apologize for the inconvenience and will provide an update soon.
Posted Jul 28, 2022 - 10:34 MST
This incident affected: Virtual School Services (Imagine Instructional Services), Academies (Edgenuity Virtual Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Courseware (Imagine Edgenuity), and Supplemental & Intervention (Imagine Pathblazer, Imagine MyPath Legacy, Imagine Purpose Prep 6-12).