Educators and Students may experience outdated rosters.

Incident Report for Imagine Learning

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 04:44 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2026 - 07:59 MST

Identified

Our team is actively investigating an issue impacting users of multiple products.

Changes to rosters made within the last 12 hours may not yet be reflected across some Imagine Learning products.

We apologize for the inconvenience and will provide an update soon.
Posted Apr 08, 2026 - 07:26 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Language & Literacy, Imagine Español, Imagine Galileo, Imagine Purpose K-5, Imagine Math, Imagine Math Facts, Imagine Purpose 6-12, Imagine+ Assessment) and Core Curriculum (Dragonfly, StudySync, Traverse).