Imagine Language & Literacy and Imagine Español: Users Cannot Log In or Use the Applications
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Jul 16, 2024 - 01:27 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Language & Literacy and Imagine Español.

Students and Educators cannot log in or use these applications.

We apologize for the inconvenience and will provide an update soon.
Posted Jul 16, 2024 - 00:33 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy, Imagine Español).