Imagine Language and Literacy reports performance degradation
Incident Report for Imagine Learning
Resolved
We are happy to report that users of Imagine Language & Literacy should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Feb 14, 2023 - 13:35 MST
Identified
Our team has identified the cause of the issue and are preparing to deploy a solution. The solution will take several several hours to complete.

We will continue to update progress.
Posted Feb 13, 2023 - 11:45 MST
Investigating
Our team has not yet identified the cause of the issue. We will continue to update progress.

Your patience is appreciated.
Posted Feb 13, 2023 - 09:34 MST
Monitoring
Our team is actively investigating an issue impacting users of Imagine Language and Literacy.

Educators may experience delays viewing reports or reports may be out of sync.

We apologize for the inconvenience and will provide an update soon.
Posted Feb 10, 2023 - 16:00 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy).