Imagine Edgenuity and Imagine Odysseyware - Slow Page Load and Intermittent Errors
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Feb 09, 2023 - 22:20 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Feb 09, 2023 - 21:59 MST
Identified
Our team is actively investigating an issue where some users of Imagine Edgenuity and Imagine Odysseyware are experiencing slow page load and intermittent errors

We apologize for the inconvenience and will provide an update soon.
Posted Feb 09, 2023 - 21:29 MST
This incident affected: Courseware (Imagine Edgenuity), Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Virtual School Services (Imagine Instructional Services), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose 6-12).