We are happy to report that users should now be able to resume activities without difficulty.
We apologize for the prior inconvenience.
Posted Sep 10, 2025 - 12:09 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.
Thank you for your patience.
Posted Sep 10, 2025 - 11:57 MST
Update
We are continuing to investigate this issue.
Posted Sep 10, 2025 - 11:35 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine+ Assessment Imagine Español Imagine Galileo Imagine Language & Literacy Imagine MyPath Imagine Purpose Traverse
The user is presented a white screen when attempting to open the Customer Rostering tools.
We apologize for the inconvenience and will provide an update soon.
Posted Sep 10, 2025 - 11:34 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Language & Literacy, Imagine Español, Imagine Galileo, Imagine Purpose K-5, Imagine+ Assessment) and Core Curriculum (Traverse).