Imagine MyPath K-12, Imagine Purpose K-5, and Imagine Science Corner: Some assignments are not loading.
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Mar 11, 2024 - 03:52 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 11, 2024 - 03:45 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine MyPath K-12, Imagine Purpose K-5, and Imagine Science Corner.

Some students are not able to open lessons.

We apologize for the inconvenience and will provide an update soon.
Posted Mar 11, 2024 - 03:06 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Purpose K-5, Imagine Science Corner).