Imagine MyPath K-12 : Some assignments are not loading
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 06:02 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2024 - 05:54 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 15, 2024 - 05:31 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine MyPath K-12.

Some students may encounter issues when loading assignments.

We apologize for the inconvenience and will provide an update soon.
Posted Mar 15, 2024 - 05:13 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Purpose K-5, Imagine Science Corner).