Imagine Edgenuity Scoring Alerts Appearing for Auto-Graded Activities

Incident Report for Imagine Learning

Monitoring

Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Apr 24, 2026 - 10:34 MST

Identified

Our team has identified the cause of the issue and are preparing to deploy a solution.

We will continue to update progress.
Posted Apr 24, 2026 - 08:14 MST

Investigating

Our team is actively investigating an issue impacting users of Imagine Edgenuity.

Educators - Some Imagine Edgenuity courses have scoring alerts appearing for uncounted or auto-graded activities.

We apologize for the inconvenience and will provide an update soon.
Posted Apr 24, 2026 - 08:13 MST
This incident affects: Courseware (Imagine Edgenuity), Virtual School Services (Imagine Instructional Services), and Academies (Brightspire Virtual Schools, Giant Campus, Ignitia Virtual Academy, Imagine Learning Excellence Academy, Park City Independent).