Imagine MyPath K-12, Imagine Lectura, Imagine Math Report Information Delayed
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Mar 16, 2023 - 20:59 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Mar 16, 2023 - 19:51 MST
Identified
Our team has identified the cause of the issue and are preparing to deploy a solution.

We will continue to update progress.
Posted Mar 16, 2023 - 19:20 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine MyPath K-12, Imagine Lectura, and Imagine Math.

Report information is delayed and not current.

We apologize for the inconvenience and will provide an update soon.
Posted Mar 16, 2023 - 17:30 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Lectura, Imagine Math).