Multiple Products - Users Cannot Log In

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Mar 10, 2026 - 21:34 MST

Investigating

We are currently investigating an issue affecting users’ ability to log in. We apologize for the inconvenience and will provide an update soon.
Posted Mar 10, 2026 - 21:19 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Language & Literacy, Imagine Español, Imagine Galileo, Imagine Purpose K-5, Imagine Math, Imagine Math Facts) and Core Curriculum (Dragonfly, StudySync, Traverse).