Edgenuity Courseware is currently under maintenance.
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Feb 08, 2022 - 19:55 MST
Update
We are continuing to investigate this issue.
Posted Feb 08, 2022 - 19:55 MST
Investigating
Edgenuity Courseware is currently under maintenance during this period users might experience a slight interruption of service and may need to clear browser cache or log in or out to resume operation.
Posted Feb 08, 2022 - 17:34 MST
This incident affected: Courseware (Imagine Edgenuity).