Imagine Edgenuity - Users may experience errors when launching activities
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Nov 06, 2024 - 12:16 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2024 - 12:14 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity for CTE courses.

An error is displayed when students attempt to launch an activity.

We apologize for the inconvenience and will provide an update soon.
Posted Nov 06, 2024 - 12:10 MST
This incident affected: Courseware (Imagine Edgenuity, Imagine EdgeEX), Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Virtual School Services (Imagine Instructional Services), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose 6-12).