Imagine Language & Literacy and Imagine Español Down
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Dec 14, 2022 - 15:26 MST
Identified
Our team has identified the cause of the issue and are preparing to deploy a solution.

We will continue to update progress.
Posted Dec 14, 2022 - 15:01 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy, Imagine Español).