Imagine Odysseyware - Users Unable to Log In
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Nov 13, 2023 - 13:57 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Odysseyware.

Students and educators cannot log in or use Imagine Odysseyware.

We apologize for the inconvenience and will provide an update soon.
Posted Nov 13, 2023 - 13:51 MST
This incident affected: Virtual School Services (Imagine Instructional Services), Courseware (Imagine Odysseyware), and Academies (Ignitia Virtual Academy).