Imagine Robotify - Users Cannot Log In
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted May 11, 2024 - 09:42 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Robotify.

Students and educators see an error message when attempting to log in.

We apologize for the inconvenience and will provide an update soon.
Posted May 11, 2024 - 09:32 MST
This incident affected: Supplemental & Intervention (Imagine Robotify).