Imagine Learning Twig Science users cannot log in
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Jul 25, 2023 - 05:54 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Jul 25, 2023 - 05:29 MST
Investigating
Our team is actively investigating an issue impacting users of app.twigscience.com and ms.twigscience.com

Students and Educators cannot log in currently.

We apologize for the inconvenience and will provide an update soon.
Posted Jul 25, 2023 - 04:51 MST
This incident affected: Core Curriculum (Twig Science).