Delays in Benchmark scores (All ImagineMath)
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Feb 28, 2022 - 13:28 MST
Monitoring
Our team implemented a solution, and we are actively monitoring to ensure no further issues.
Thank you for your patience.
Posted Feb 28, 2022 - 10:07 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 25, 2022 - 16:40 MST
This incident affected: Supplemental & Intervention (Imagine Math).