Imagine Language & Literacy and Imagine Español - Student Errors

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Oct 17, 2024 - 07:21 MST

Monitoring

Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Oct 17, 2024 - 06:56 MST

Identified

Our team has identified an issue impacting users of Imagine Language & Literacy and Imagine Español.

Students may be seeing errors when logging in or using the platform.

We apologize for the inconvenience and will provide an update soon.
Posted Oct 17, 2024 - 06:36 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy, Imagine Español).