Imagine Edgenuity Educators Experiencing Slowness
Incident Report for Imagine Learning
Resolved
We are happy to report that Educators should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Oct 28, 2022 - 12:29 MST
Monitoring
Our products are now working as expected. We are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Oct 28, 2022 - 07:14 MST
Identified
Our team has identified an issue impacting users of Imagine Edgenuity - as well as - Imagine MyPath Legacy and Imagine Purpose Prep 6-12.

Educators may be experiencing slowness while loading pages.

We apologize for the inconvenience and will provide an update soon.
Posted Oct 28, 2022 - 05:45 MST
This incident affected: Academies (Edgenuity Virtual Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Virtual School Services (Imagine Instructional Services), Courseware (Imagine Edgenuity), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose Prep 6-12).