Multiple Products - Error When Loading Activities in Some Courses

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Apr 30, 2024 - 08:35 MST

Monitoring

Our team has confirmed the vendor has resolved the issue. We will continue to monitor to ensure no further issues.

Thank you for your patience.
Posted Apr 30, 2024 - 08:14 MST

Identified

Our team has identified that a cloud provider is experiencing a service interruption affecting some activities.

We will continue to provide updates on the progress.
Posted Apr 30, 2024 - 07:31 MST

Investigating

Our team is actively investigating an issue impacting some students of Imagine Edgenuity, Imagine Odysseyware, and Imagine EdgeEX.

Students may encounter issues loading some activities.

We apologize for the inconvenience and will provide an update soon.
Posted Apr 30, 2024 - 06:41 MST
This incident affected: Courseware (Imagine Edgenuity, Imagine EdgeEX, Imagine Odysseyware) and Virtual School Services (Imagine Instructional Services).