Imagine MyPath K-12, Imagine Purpose K-5, and Imagine Science Corner - Items Slow or Not Loading
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Sep 20, 2024 - 21:42 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Sep 20, 2024 - 21:40 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine MyPath K-12, Imagine Purpose K-5, and Imagine Science Corner.

After the maintenance, we are observing some items are slow to load or not loading for students and teachers.

We apologize for the inconvenience and will provide an update soon.
Posted Sep 20, 2024 - 20:43 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Purpose K-5, Imagine Science Corner).